PHP and WordPress Version Checks Coming to Themes

PHP and WordPress Version Checks Coming to Themes

wptavern.com wptavern.com3 days ago in #Web Design Love64

PHP and WordPress version checks are coming to the WordPress theme system — finally. The feature was pulled into core WordPress three days ago. It will prevent end-users from installing or activating a theme that is incompatible with their current version of PHP or WordPress. The change is slated to land in WordPress 5.5. This feature has long been on many theme authors’ wish lists, particularly PHP version checking. Plugins authors gained the ability to support specific PHP versions starting with WordPress 5.2. However, theme authors were left feeling like the second-class citizens they usually are when it comes to the addition of core features, waiting patiently as plugin authors received the new and shiny tools they were looking forward to. Previously, the code for manually handling version checking within individual themes was more complex than in plugins. Theme authors needed to run compatibility checks after theme switch and block theme previews in the customizer using two different methods, depending on the user’s WordPress version. That is assuming theme authors were covering all their bases. Users had no real way of knowing whether a theme would work on their site before installing and attempting to activate it. It was a poor user experience, even when a theme gracefully failed for the end-user. This user experience has also held back some theme authors from transitioning to newer versions of PHP. For years, many were supporting PHP 5.2. Slowly, some of these same authors are now making the move toward newer features up to PHP 5.6, which is now the minimum that WordPress supports. However, not many have made the jump to PHP 7 and newer. Until now, there has been no mechanism for letting the user know they need to upgrade their PHP to use a particular theme. Some theme authors may choose to continue supporting older versions of PHP, such as 5.6, for a potentially wider user base. However, developers who want to switch to newer features can now do so with the support of the core platform. Changes for Users New WordPress and PHP versions added to Twenty Twenty theme. Users who are browsing the WordPress theme directory may begin to notice new information available for some themes. Similar to plugins, visitors should see a WordPress Version and PHP Version listed for some themes. For example, the Twenty Twenty theme now lists the following minimum requirements: WordPress Version: 4.7 or higher PHP Version: 5.2.4 or higher Not all themes will have these numbers listed yet. It will take some time before older themes are updated with the data required to populate these fields. In WordPress 5.5, the admin interface for themes will change. When attempting to install or activate a theme, WordPress will prevent such actions. If a user searches for a theme that has an incompatible WordPress or PHP version, the normal installation button will be replaced with a disabled button that reads “Cannot Install.” If a theme is installed but not activated, the activation link will similarly be replaced with a disabled “Cannot Activate” button. Users will also not be allowed to live preview incompatible themes. Cannot activate Twenty Twenty theme with incompatible PHP version. The feature works the same from within the customizer interface as it does via the themes screen in the WordPress admin. Changes for Theme Authors The WordPress Themes Team recently announced two new required headers for theme authors to place in their style.css files.  » Read More

Like to keep reading?

This article first appeared on wptavern.com. If you'd like to keep reading, follow the white rabbit.

View Full Article

Leave a Reply